PIC Vietnam

Go Back   PIC Vietnam > Microchip PIC > Các ngôn ngữ lập trình khác (CCS C, HT PIC,...)

Tài trợ cho PIC Vietnam
Trang chủ Đăng Kí Hỏi/Ðáp Thành Viên Lịch Tìm Kiếm Bài Trong Ngày Ðánh Dấu Ðã Ðọc Vi điều khiển

 
 
Ðiều Chỉnh Xếp Bài
Prev Previous Post   Next Post Next
Old 09-05-2013, 10:24 AM   #1
mrcuongcon
Nhập môn đệ tử
 
Tham gia ngày: May 2007
Bài gửi: 1
:
Có phải lỗi compiler CCS 4.140

Mình đang sử dụng PIC 12F1822 dùng CCS gặp lỗi sau : Config cho CCP1 chạy PWM thì :
-Nếu set giá trị duty từ 0-200 và 257-512 thì ok nhưng trong khoảng 200-256 lại không thấy xung đầu ra .
-Nếu remap chân CCP1 ra chân RA5 ( bình thường là RA2) thì cũng không chạy được.
Nhờ các cao thủ giúp đỡ!
Xin chân thành cám ơn!
Dưới đây là bài lập trình
//----------------------------------
#include <12f1822.h>
#use delay(clock=8mhz)
#FUSES INTRC_IO, NOMCLR, CPD,PROTECT, NOWDT, BROWNOUT, PUT
//#use fast_io(A)
//#byte APFCON = 0x01 //CCP on RA5 // Configure CCP1 as a PWM
void main()
{
int16 x;
setup_oscillator(OSC_8MHZ | OSC_NORMAL | OSC_PLL_ON);
//setup_timer_1(T1_INTERNAL|T1_DIV_BY_1); //
setup_timer_2(T2_DIV_BY_1, 127, 1); // 31.2kHz
setup_ccp1(CCP_PWM);

set_timer1(65000);

set_tris_a (0x00); // 101111 (0=output) 5 4 3 2 1 0
PORT_a_PULLUPS(0xff); // 000000 (1=enabled) 5 4 3 2 1 0

while(true)
{
set_pwm1_duty(200);
delay_ms(100);
//x=250;
}
}
//-----------------------------------------------------
mrcuongcon vẫn chưa có mặt trong diễn đàn   Trả Lời Với Trích Dẫn
 

Ðiều Chỉnh
Xếp Bài

Quyền Sử Dụng Ở Diễn Ðàn
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Mở
Smilies đang Mở
[IMG] đang Mở
HTML đang Tắt

Chuyển đến


Múi giờ GMT. Hiện tại là 07:09 AM.


Được sáng lập bởi Đoàn Hiệp
Powered by vBulletin®
Page copy protected against web site content infringement by Copyscape
Copyright © PIC Vietnam