PIC Vietnam

Go Back   PIC Vietnam > Microchip PIC > Cơ bản về vi điều khiển và PIC > Những câu hỏi thường gặp

Tài trợ cho PIC Vietnam
Trang chủ Đăng Kí Hỏi/Ðáp Thành Viên Lịch Tìm Kiếm Bài Trong Ngày Ðánh Dấu Ðã Ðọc Vi điều khiển

Những câu hỏi thường gặp Những lỗi cơ bản thường gặp khi làm việc với PIC hoặc những vấn đề cơ bản nhất thường được hỏi trong những năm qua

 
 
Ðiều Chỉnh Xếp Bài
Prev Previous Post   Next Post Next
Old 20-08-2007, 07:06 PM   #1
tranducbinh
Đệ tử 1 túi
 
Tham gia ngày: Feb 2007
Bài gửi: 13
:
Trục trặc với 16f877a ngay từ đầu?

Chào mọi người

Minh đang thực hành 16f877a nhưng gặp một trục trặc như sau: (mong mọi người chỉ giúp)

mình thử xuất ra chân RB4 đến RB7 điện áp 5V nhưng khi dung dồng hồ đo thi không thấy lên 5V mà chỉ là ở mức 0, đôi khi là 0.02V khi để thang đo ở mức 0.1V trong khi mình mô phỏng trên proteus thì vẫn đúng. Chương trình rất đơn giản, minh nghĩ không có gì sai cả

#include<16F877A.h>
#fuses NOWDT,PUT,HS,NOPROTECT
#use delay(clock=40000000)
#use fast_io(b)
#byte portb=0x06
#bit RB1=portb.1

main()
{
set_tris_b(0b00001111);

while (true)
{
portb=0b11110000;
}

}

mình dùng thach anh 4MHz và tụ cho thạch anh là 104pF.Mình cũng nghỉ tới khả năng chip bi hư nhưng chip vẫn nap được bình thường, thấy không báo lỗi gi cả.
mình không thể tìm ra dươc sai chổ nào. Mong các bạn chi giúp với.

thay đổi nội dung bởi: tranducbinh, 21-08-2007 lúc 12:06 AM. Lý do: thiếu ý
tranducbinh vẫn chưa có mặt trong diễn đàn   Trả Lời Với Trích Dẫn
 

Ðiều Chỉnh
Xếp Bài

Quyền Sử Dụng Ở Diễn Ðàn
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Mở
Smilies đang Mở
[IMG] đang Mở
HTML đang Tắt

Chuyển đến


Múi giờ GMT. Hiện tại là 11:11 AM.


Được sáng lập bởi Đoàn Hiệp
Powered by vBulletin®
Page copy protected against web site content infringement by Copyscape
Copyright © PIC Vietnam